Thursday, 24 November 2011

YAF Polls - You already voted.

A user can't vote as it says "You already voted." when you know you haven't voted with this user account. Have you voted though with a different user account from the same machine or the same network?
By default, YAF only lets a user vote if no one using the same IP Address has already voted.
You can turn this feature off in Host Settings -> Features -> Poll Options -> Poll Votes Dependant on IP

Monday, 7 November 2011

Could not load type 'System.ServiceModel.Activation.HttpModule'


Have you started working on a .NET 4.0 project and received the following error?
Could not load type ‘System.ServiceModel.Activation.HttpModule’ from assembly ‘System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'. Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code. Exception Details: System.TypeLoadException: Could not load type ‘System.ServiceModel.Activation.HttpModule’ from assembly ‘System.ServiceModel, Version=3.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089'.

If you have, you probably have installed .Net framework 4.0 on IIS and then enable either a .Net 3.0 or 3.5 WCF feature.  To fix you need to reconfigure ASP.NET by using the following command depending on the version of ASP.NET you have installed.

IIS 32 bit

%SYSTEMROOT%\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis /iru

IIS 64 bit

%SYSTEMROOT%\Microsoft.NET\Framework64\v4.0.30319\aspnet_regiis /iru

Tuesday, 1 November 2011

SQL Server Management Studio Intellisence not refreshing on schema change

When I have been adding tables, columns etc, I've noticed that the intellisense is not updated with in the query window. The intellisense is updated however if I shutdown the management studio and re-open it. This is quite an agressive and time consuming measure.

The problem it that objects are cached in the solution so to you have to refresh the local cache.

Edit  -> Intellisense -> Refresh Local Cache (CTRL+Shift+R)